Willo - Practice Mode – Incident details

All systems operational

Practice Mode

Resolved
Operational
Started over 5 years agoLasted 1 day
Updates
  • Resolved
    Resolved

    Practice mode is now working again for all users. Thanks for your patience!

  • Investigating
    Investigating

    Practice mode is currently unavailable for some users. We are working on restoring this functionality shortly. In the meantime please proceed to 'Start Interview'.